What’s Vulnerable › Vulnerabilities

CVE-2018-7164

Description

Node.js versions 9.7.0 and later and 10.x are vulnerable and the severity is MEDIUM. A bug introduced in 9.7.0 increases the memory consumed when reading from the network into JavaScript using the net.Socket object directly as a stream. An attacker could use this cause a denial of service by sending tiny chunks of data in short succession. This vulnerability was restored by reverting to the prior behaviour.

Affected products

How to fix

Upgrade to a fixed version: Node.js 10.4.1, 9.11.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-7164 or the next vulnerability affects your stack