What’s Vulnerable › Vulnerabilities
CVE-2018-7167
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-13 · updated 2026-10-08
- Weakness: CWE-119
Description
Calling Buffer.fill() or Buffer.alloc() with some parameters can lead to a hang which could result in a Denial of Service. In order to address this vulnerability, the implementations of Buffer.alloc() and Buffer.fill() were updated so that they zero fill instead of hanging in these cases. All versions of Node.js 6.x (LTS "Boron"), 8.x (LTS "Carbon"), and 9.x are vulnerable. All versions of Node.js 10.x (Current) are NOT vulnerable.
Affected products
- Node.js: from 6.9.0 (excl.) before 6.14.3; from 8.9.0 before 8.11.3; from 9.0.0 before 9.11.2 — fixed in 6.14.3, 8.11.3, 9.11.2
How to fix
Upgrade to a fixed version: Node.js 6.14.3, 8.11.3, 9.11.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106363
- https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/
- https://security.gentoo.org/glsa/202003-48
- http://www.securityfocus.com/bid/106363
- https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/
- https://security.gentoo.org/glsa/202003-48
Get alerted when CVE-2018-7167 or the next vulnerability affects your stack