What’s Vulnerable › Vulnerabilities
CVE-2018-7187
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 63.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-02-16 · updated 2026-06-17
- Weakness: CWE-78
Description
The "go get" implementation in Go 1.9.4, when the -insecure command-line option is used, does not validate the import path (get/vcs.go only checks for "://" anywhere in the string), which allows remote attackers to execute arbitrary OS commands via a crafted web site.
Affected products
- Debian Linux: 7.0, 9.0
- Go: before 1.9.5; from 1.10 before 1.10.1 — fixed in 1.10.1, 1.9.5
How to fix
Upgrade to a fixed version: Go 1.10.1, 1.9.5. Check the vendor advisory for mitigations.
References
- https://gist.github.com/SLAYEROWNER/b2a358f13ab267f2e9543bb9f9320ffc
- https://github.com/golang/go/issues/23867
- https://lists.debian.org/debian-lts-announce/2018/02/msg00029.html
- https://security.gentoo.org/glsa/201804-12
- https://www.debian.org/security/2019/dsa-4379
- https://www.debian.org/security/2019/dsa-4380
- https://gist.github.com/SLAYEROWNER/b2a358f13ab267f2e9543bb9f9320ffc
- https://github.com/golang/go/issues/23867
- https://lists.debian.org/debian-lts-announce/2018/02/msg00029.html
- https://security.gentoo.org/glsa/201804-12
- https://www.debian.org/security/2019/dsa-4379
- https://www.debian.org/security/2019/dsa-4380
Get alerted when CVE-2018-7187 or the next vulnerability affects your stack