What’s Vulnerable › Vulnerabilities
CVE-2018-7307
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-06 · updated 2026-06-17
- Weakness: CWE-352
Description
The Auth0 Auth0.js library before 9.3 has CSRF because it mishandles the case where the authorization response lacks the state parameter.
Affected products
- auth0.js: before 9.3 — fixed in 9.3
How to fix
Upgrade to a fixed version: auth0.js 9.3. Check the vendor advisory for mitigations.
References
- https://auth0.com/docs/security/bulletins/cve-2018-7307
- https://auth0.com/docs/security/bulletins/cve-2018-7307
Get alerted when CVE-2018-7307 or the next vulnerability affects your stack