What’s Vulnerable › Vulnerabilities
CVE-2018-7409
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-22 · updated 2026-06-17
- Weakness: CWE-119
Description
In unixODBC before 2.3.5, there is a buffer overflow in the unicode_to_ansi_copy() function in DriverManager/__info.c.
Affected products
- unixodbc: before 2.3.5 — fixed in 2.3.5
How to fix
Upgrade to a fixed version: unixodbc 2.3.5. Check the vendor advisory for mitigations.
References
- http://www.unixodbc.org/unixODBC-2.3.5.tar.gz
- https://access.redhat.com/errata/RHSA-2019:2336
- https://sourceforge.net/projects/unixodbc/files/unixODBC/2.3.5/ChangeLog/download
- http://www.unixodbc.org/unixODBC-2.3.5.tar.gz
- https://access.redhat.com/errata/RHSA-2019:2336
- https://sourceforge.net/projects/unixodbc/files/unixODBC/2.3.5/ChangeLog/download
Get alerted when CVE-2018-7409 or the next vulnerability affects your stack