What’s Vulnerable › Vulnerabilities
CVE-2018-7427
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in Splunk Web in Splunk Enterprise 6.0.x before 6.0.14, 6.1.x before 6.1.13, 6.2.x before 6.2.14, 6.3.x before 6.3.10, 6.4.x before 6.4.7, and 6.5.x before 6.5.3; and Splunk Light before 6.6.0 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Affected products
- Splunk Enterprise: before 6.6.0; from 6.0.0 before 6.0.14; from 6.1.0 before 6.1.13; from 6.2.0 before 6.2.14; from 6.3.0 before 6.3.10; from 6.4.0 before 6.4.7 — fixed in 6.0.14, 6.1.13, 6.2.14, 6.3.10, 6.4.7, 6.5.3
How to fix
Upgrade to a fixed version: Splunk Enterprise 6.0.14, 6.1.13, 6.2.14, 6.3.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-7427 or the next vulnerability affects your stack