What’s Vulnerable › Vulnerabilities
CVE-2018-7435
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-02-23 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in FreeXL before 1.0.5. There is a heap-based buffer over-read in the freexl::destroy_cell function.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- Freexl Project Freexl: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: Freexl Project Freexl 1.0.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1547879
- https://groups.google.com/forum/#%21topic/spatialite-users/b-d9iB5TDPE
- https://lists.debian.org/debian-lts-announce/2018/03/msg00000.html
- https://security.gentoo.org/glsa/202007-44
- https://www.debian.org/security/2018/dsa-4129
- https://bugzilla.redhat.com/show_bug.cgi?id=1547879
- https://groups.google.com/forum/#%21topic/spatialite-users/b-d9iB5TDPE
- https://lists.debian.org/debian-lts-announce/2018/03/msg00000.html
- https://security.gentoo.org/glsa/202007-44
- https://www.debian.org/security/2018/dsa-4129
Get alerted when CVE-2018-7435 or the next vulnerability affects your stack