What’s Vulnerable › Vulnerabilities
CVE-2018-7465
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-04-26 · updated 2026-06-17
- Weakness: CWE-79
Description
An XSS issue was discovered in VirtueMart before 3.2.14. All the textareas in the backend of the plugin can be closed by simply adding </textarea> to the value and saving the product/config. By editing back the product/config, the editor's browser will execute everything after the </textarea>, leading to a possible XSS.
Affected products
- virtuemart.net Virtuemart component for Joomla: before 3.2.14 — fixed in 3.2.14
How to fix
Upgrade to a fixed version: virtuemart.net Virtuemart component for Joomla 3.2.14. Check the vendor advisory for mitigations.
References
- http://virtuemart.net/news/489-virtuemart-3-2-14-security-release-and-enhanced-invoice-handling
- https://imgur.com/a/Hf6JD
- https://www.exploit-db.com/exploits/44625/
- http://virtuemart.net/news/489-virtuemart-3-2-14-security-release-and-enhanced-invoice-handling
- https://imgur.com/a/Hf6JD
- https://www.exploit-db.com/exploits/44625/
Get alerted when CVE-2018-7465 or the next vulnerability affects your stack