What’s Vulnerable › Vulnerabilities
CVE-2018-7480
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-25 · updated 2026-06-17
- Weakness: CWE-415
Description
The blkcg_init_queue function in block/blk-cgroup.c in the Linux kernel before 4.11 allows local users to cause a denial of service (double free) or possibly have unspecified other impact by triggering a creation failure.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04
- Debian Linux: 9.0
- Linux kernel: from 4.1.41 before 4.1.51; from 4.3 before 4.4.123; from 4.5 before 4.9.89; from 4.10 before 4.11 — fixed in 4.1.51, 4.11, 4.4.123, 4.9.89
How to fix
Upgrade to a fixed version: Linux kernel 4.1.51, 4.11, 4.4.123, 4.9.89. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9b54d816e00425c3a517514e0d677bb3cec49258
- https://github.com/torvalds/linux/commit/9b54d816e00425c3a517514e0d677bb3cec49258
- https://usn.ubuntu.com/3654-1/
- https://usn.ubuntu.com/3654-2/
- https://usn.ubuntu.com/3656-1/
- https://www.debian.org/security/2018/dsa-4188
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9b54d816e00425c3a517514e0d677bb3cec49258
- https://github.com/torvalds/linux/commit/9b54d816e00425c3a517514e0d677bb3cec49258
- https://usn.ubuntu.com/3654-1/
- https://usn.ubuntu.com/3654-2/
- https://usn.ubuntu.com/3656-1/
- https://www.debian.org/security/2018/dsa-4188
Get alerted when CVE-2018-7480 or the next vulnerability affects your stack