What’s Vulnerable › Vulnerabilities
CVE-2018-7490
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 69.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-02-26 · updated 2026-06-17
- Weakness: CWE-22
Description
uWSGI before 2.0.17 mishandles a DOCUMENT_ROOT check during use of the --php-docroot option, allowing directory traversal.
Affected products
- Debian Linux: 8.0, 9.0
- Unbit Uwsgi: before 2.0.17 — fixed in 2.0.17
How to fix
Upgrade to a fixed version: Unbit Uwsgi 2.0.17. Check the vendor advisory for mitigations.
References
- https://uwsgi-docs.readthedocs.io/en/latest/Changelog-2.0.17.html
- https://www.debian.org/security/2018/dsa-4142
- https://www.exploit-db.com/exploits/44223/
- https://uwsgi-docs.readthedocs.io/en/latest/Changelog-2.0.17.html
- https://www.debian.org/security/2018/dsa-4142
- https://www.exploit-db.com/exploits/44223/
Get alerted when CVE-2018-7490 or the next vulnerability affects your stack