What’s Vulnerable › Vulnerabilities
CVE-2018-7556
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-28 · updated 2026-06-17
- Weakness: CWE-200
Description
LimeSurvey 2.6.x before 2.6.7, 2.7x.x before 2.73.1, and 3.x before 3.4.2 mishandles application/controller/InstallerController.php after installation, which allows remote attackers to access the configuration file.
Affected products
- Debian Linux: 7.0
- LimeSurvey: from 2.6.0 before 2.6.7; from 2.7.0 before 2.73.1; from 3.0.0 before 3.4.2 — fixed in 2.6.7, 2.73.1, 3.4.2
How to fix
Upgrade to a fixed version: LimeSurvey 2.6.7, 2.73.1, 3.4.2. Check the vendor advisory for mitigations.
References
- https://www.limesurvey.org/about-us/news/2075-limesurvey-security-advisory-02-2018
- https://www.limesurvey.org/about-us/news/2075-limesurvey-security-advisory-02-2018
Get alerted when CVE-2018-7556 or the next vulnerability affects your stack