What’s Vulnerable › Vulnerabilities
CVE-2018-7577
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-24 · updated 2026-06-17
- Weakness: CWE-20
Description
Memcpy parameter overlap in Google Snappy library 1.1.4, as used in Google TensorFlow before 1.7.1, could result in a crash or read from other parts of process memory.
Affected products
- Google Snappy: 1.1.4
- tensorflow: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: tensorflow 1.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-005.md
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-005.md
Get alerted when CVE-2018-7577 or the next vulnerability affects your stack