What’s Vulnerable › Vulnerabilities
CVE-2018-7584
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 87.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-01 · updated 2026-06-17
- Weakness: CWE-119
Description
In PHP through 5.6.33, 7.0.x before 7.0.28, 7.1.x through 7.1.14, and 7.2.x through 7.2.2, there is a stack-based buffer under-read while parsing an HTTP response in the php_stream_url_wrap_http_ex function in ext/standard/http_fopen_wrapper.c. This subsequently results in copying a large string.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- PHP: through 5.6.33; from 7.0.0 before 7.0.28; from 7.1.0 through 7.1.14; from 7.2.0 through 7.2.2 — fixed in 7.0.28
How to fix
Upgrade to a fixed version: PHP 7.0.28. Check the vendor advisory for mitigations.
References
- http://php.net/ChangeLog-7.php
- http://www.securityfocus.com/bid/103204
- http://www.securitytracker.com/id/1041607
- https://access.redhat.com/errata/RHSA-2019:2519
- https://bugs.php.net/bug.php?id=75981
- https://github.com/php/php-src/commit/523f230c831d7b33353203fa34aee4e92ac12bba
- https://lists.debian.org/debian-lts-announce/2018/03/msg00030.html
- https://lists.debian.org/debian-lts-announce/2018/06/msg00005.html
- https://usn.ubuntu.com/3600-1/
- https://usn.ubuntu.com/3600-2/
- https://www.debian.org/security/2018/dsa-4240
- https://www.exploit-db.com/exploits/44846/
Get alerted when CVE-2018-7584 or the next vulnerability affects your stack