What’s Vulnerable › Vulnerabilities
CVE-2018-7602: Drupal Core Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-04-13
- EPSS: 99.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-19 · updated 2026-10-02
- Weakness: CWE-94
Description
A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being compromised. This vulnerability is related to Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-002. Both SA-CORE-2018-002 and this vulnerability are being exploited in the wild.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- Drupal: from 7.0 before 7.59; from 8.4.0 before 8.4.8; from 8.5.0 before 8.5.3 — fixed in 7.59, 8.4.8, 8.5.3
How to fix
Upgrade to a fixed version: Drupal 7.59, 8.4.8, 8.5.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103985
- http://www.securitytracker.com/id/1040754
- https://lists.debian.org/debian-lts-announce/2018/04/msg00030.html
- https://www.debian.org/security/2018/dsa-4180
- https://www.drupal.org/sa-core-2018-004
- https://www.exploit-db.com/exploits/44542/
- https://www.exploit-db.com/exploits/44557/
- http://www.securityfocus.com/bid/103985
- http://www.securitytracker.com/id/1040754
- https://lists.debian.org/debian-lts-announce/2018/04/msg00030.html
- https://www.debian.org/security/2018/dsa-4180
- https://www.drupal.org/sa-core-2018-004
Get alerted when CVE-2018-7602 or the next vulnerability affects your stack