What’s Vulnerable › Vulnerabilities
CVE-2018-7651
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-04 · updated 2026-06-17
- Weakness: CWE-400
Description
index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode functionality via a long base64 hash string.
Affected products
- Ssri Project Ssri: before 5.2.2 — fixed in 5.2.2
How to fix
Upgrade to a fixed version: Ssri Project Ssri 5.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/zkat/ssri/commit/d0ebcdc22cb5c8f47f89716d08b3518b2485d65d
- https://github.com/zkat/ssri/issues/10
- https://nodesecurity.io/advisories/565
- https://github.com/zkat/ssri/commit/d0ebcdc22cb5c8f47f89716d08b3518b2485d65d
- https://github.com/zkat/ssri/issues/10
- https://nodesecurity.io/advisories/565
Get alerted when CVE-2018-7651 or the next vulnerability affects your stack