What’s Vulnerable › Vulnerabilities
CVE-2018-7685: libzypp does not reevaluate malicious rpms once downloaded
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-31 · updated 2026-06-17
- Weakness: CWE-358
Description
The decoupled download and installation steps in libzypp before 17.5.0 could lead to a corrupted RPM being left in the cache, where a later call would not display the corrupted RPM warning and allow installation, a problem caused by malicious warnings only displayed during download.
Affected products
- SUSE libzypp: before 17.5.0 — fixed in 17.5.0
How to fix
Upgrade to a fixed version: SUSE libzypp 17.5.0. Check the vendor advisory for mitigations.
References
- http://lists.suse.com/pipermail/sle-security-updates/2018-August/004510.html
- https://bugzilla.suse.com/show_bug.cgi?id=1091624
- https://www.suse.com/de-de/security/cve/CVE-2018-7685/
- http://lists.suse.com/pipermail/sle-security-updates/2018-August/004510.html
- https://bugzilla.suse.com/show_bug.cgi?id=1091624
- https://www.suse.com/de-de/security/cve/CVE-2018-7685/
Get alerted when CVE-2018-7685 or the next vulnerability affects your stack