What’s Vulnerable › Vulnerabilities
CVE-2018-7711
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-05 · updated 2026-06-17
- Weakness: CWE-347
Description
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
Affected products
- Debian Linux: 7.0
- simplesamlphp saml2: from 1.0.0 before 1.10.6; from 2.0.0 before 2.3.8; from 3.0.0 before 3.1.4 — fixed in 1.10.6, 2.3.8, 3.1.4
- simplesamlphp: before 1.15.4 — fixed in 1.15.4
How to fix
Upgrade to a fixed version: simplesamlphp saml2 1.10.6, 2.3.8, 3.1.4; simplesamlphp 1.15.4. Check the vendor advisory for mitigations.
References
- https://github.com/simplesamlphp/saml2/commit/4f6af7f69f29df8555a18b9bb7b646906b45924d
- https://lists.debian.org/debian-lts-announce/2018/03/msg00017.html
- https://simplesamlphp.org/security/201803-01
- https://github.com/simplesamlphp/saml2/commit/4f6af7f69f29df8555a18b9bb7b646906b45924d
- https://lists.debian.org/debian-lts-announce/2018/03/msg00017.html
- https://simplesamlphp.org/security/201803-01
Get alerted when CVE-2018-7711 or the next vulnerability affects your stack