What’s Vulnerable › Vulnerabilities
CVE-2018-7937
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-04 · updated 2026-06-17
Description
In Huawei HiRouter-CD20-10 with the versions before 1.9.6 and WS5200-10 with the versions before 1.9.6, there is a plug-in signature bypass vulnerability due to insufficient plug-in verification. An attacker may tamper with a legitimate plug-in to build a malicious plug-in and trick users into installing it. Successful exploit could allow the attacker to obtain the root permission of the device and take full control over the device.
Affected products
- Huawei Hirouter-Cd20 Firmware: before hirouter-cd20-10_1.9.6 — fixed in hirouter-cd20-10_1.9.6
- Huawei Ws5200-10 Firmware: before ws5200-10_1.9.6 — fixed in ws5200-10_1.9.6
How to fix
Upgrade to a fixed version: Huawei Hirouter-Cd20 Firmware hirouter-cd20-10_1.9.6; Huawei Ws5200-10 Firmware ws5200-10_1.9.6. Check the vendor advisory for mitigations.
References
- http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20180827-01-gateway-en
- http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20180827-01-gateway-en
Get alerted when CVE-2018-7937 or the next vulnerability affects your stack