What’s Vulnerable › Vulnerabilities
CVE-2018-8004
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-29 · updated 2026-06-17
- Weakness: CWE-444
Description
There are multiple HTTP smuggling and cache poisoning issues when clients making malicious requests interact with Apache Traffic Server (ATS). This affects versions 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.
Affected products
- Apache Software Foundation Apache Traffic Server: from 6.0.0 through 6.2.2; from 7.0.0 through 7.1.3
- Debian Linux: 9.0
References
- http://www.securityfocus.com/bid/105192
- https://github.com/apache/trafficserver/pull/3192
- https://github.com/apache/trafficserver/pull/3201
- https://github.com/apache/trafficserver/pull/3231
- https://github.com/apache/trafficserver/pull/3251
- https://lists.apache.org/thread.html/7df882eb09029a4460768a61f88a30c9c30c9dc88e9bcc6e19ba24d5%40%3Cusers.trafficserver.apache.org%3E
- https://www.debian.org/security/2018/dsa-4282
- http://www.securityfocus.com/bid/105192
- https://github.com/apache/trafficserver/pull/3192
- https://github.com/apache/trafficserver/pull/3201
- https://github.com/apache/trafficserver/pull/3231
- https://github.com/apache/trafficserver/pull/3251
Get alerted when CVE-2018-8004 or the next vulnerability affects your stack