What’s Vulnerable › Vulnerabilities
CVE-2018-8018
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-20 · updated 2026-06-17
- Weakness: CWE-502
Description
In Apache Ignite before 2.4.8 and 2.5.x before 2.5.3, the serialization mechanism does not have a list of classes allowed for serialization/deserialization, which makes it possible to run arbitrary code when 3-rd party vulnerable classes are present in Ignite classpath. The vulnerability can be exploited if the one sends a specially prepared form of a serialized object to GridClientJdkMarshaller deserialization endpoint.
Affected products
- Apache Software Foundation Apache Ignite: before 2.4.8; from 2.5.0 (excl.) before 2.5.3 — fixed in 2.4.8, 2.5.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ignite 2.4.8, 2.5.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104911
- https://access.redhat.com/errata/RHSA-2018:3768
- https://lists.apache.org/thread.html/e0fdf53114a321142ecfa5cfa17658090f0b4e1677de431e329b37ab%40%3Cdev.ignite.apache.org%3E
- http://www.securityfocus.com/bid/104911
- https://access.redhat.com/errata/RHSA-2018:3768
- https://lists.apache.org/thread.html/e0fdf53114a321142ecfa5cfa17658090f0b4e1677de431e329b37ab%40%3Cdev.ignite.apache.org%3E
Get alerted when CVE-2018-8018 or the next vulnerability affects your stack