What’s Vulnerable › Vulnerabilities
CVE-2018-8021
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 53.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-11-07 · updated 2026-06-17
- Weakness: CWE-502
Description
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.
Affected products
- Apache Superset: before 0.23 — fixed in 0.23
How to fix
Upgrade to a fixed version: Apache Superset 0.23. Check the vendor advisory for mitigations.
References
- https://github.com/apache/incubator-superset/pull/4243
- https://www.exploit-db.com/exploits/45933/
- https://github.com/apache/incubator-superset/pull/4243
- https://www.exploit-db.com/exploits/45933/
Get alerted when CVE-2018-8021 or the next vulnerability affects your stack