What’s Vulnerable › Vulnerabilities
CVE-2018-8028
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-23 · updated 2026-06-17
- Weakness: CWE-862
Description
An authenticated user can execute ALTER TABLE EXCHANGE PARTITIONS without being authorized by Apache Sentry before 2.0.1. This can allow an attacker unauthorized access to the partitioned data of a Sentry protected table and can allow an attacker to remove data from a Sentry protected table.
Affected products
- Apache Software Foundation Apache Sentry: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Sentry 2.0.1. Check the vendor advisory for mitigations.
References
- https://cwiki.apache.org/confluence/display/SENTRY/Vulnerabilities+found+in+Apache+Sentry
- https://cwiki.apache.org/confluence/display/SENTRY/Vulnerabilities+found+in+Apache+Sentry
Get alerted when CVE-2018-8028 or the next vulnerability affects your stack