What’s Vulnerable › Vulnerabilities
CVE-2018-8040
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-29 · updated 2026-06-17
- Weakness: CWE-668
Description
Pages that are rendered using the ESI plugin can have access to the cookie header when the plugin is configured not to allow access. This affects Apache Traffic Server (ATS) versions 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.
Affected products
- Apache Software Foundation Apache Traffic Server: from 6.0.0 through 6.2.2; from 7.0.0 through 7.1.3
- Debian Linux: 9.0
References
- http://www.securityfocus.com/bid/105181
- https://github.com/apache/trafficserver/pull/3926
- https://lists.apache.org/thread.html/36b3df68fe7311965f6bc4630ca413d2aa99d8f1d53affda85ea70d7%40%3Cusers.trafficserver.apache.org%3E
- https://lists.apache.org/thread.html/cc7aa2ce1c6f4fe0c6bfef517763cdaad30ec7bcb0115b73f73f3c01%40%3Cusers.trafficserver.apache.org%3E
- https://www.debian.org/security/2018/dsa-4282
- http://www.securityfocus.com/bid/105181
- https://github.com/apache/trafficserver/pull/3926
- https://lists.apache.org/thread.html/36b3df68fe7311965f6bc4630ca413d2aa99d8f1d53affda85ea70d7%40%3Cusers.trafficserver.apache.org%3E
- https://lists.apache.org/thread.html/cc7aa2ce1c6f4fe0c6bfef517763cdaad30ec7bcb0115b73f73f3c01%40%3Cusers.trafficserver.apache.org%3E
- https://www.debian.org/security/2018/dsa-4282
Get alerted when CVE-2018-8040 or the next vulnerability affects your stack