What’s Vulnerable › Vulnerabilities
CVE-2018-8097
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-14 · updated 2026-06-17
- Weakness: CWE-94
Description
io/mongo/parser.py in Eve (aka pyeve) before 0.7.5 allows remote attackers to execute arbitrary code via Code Injection in the where parameter.
Affected products
- Python-Eve Eve: before 0.7.5 — fixed in 0.7.5
How to fix
Upgrade to a fixed version: Python-Eve Eve 0.7.5. Check the vendor advisory for mitigations.
References
- https://github.com/pyeve/eve/commit/f8f7019ffdf9b4e05faf95e1f04e204aa4c91f98
- https://github.com/pyeve/eve/issues/1101
- https://github.com/pyeve/eve/commit/f8f7019ffdf9b4e05faf95e1f04e204aa4c91f98
- https://github.com/pyeve/eve/issues/1101
Get alerted when CVE-2018-8097 or the next vulnerability affects your stack