What’s Vulnerable › Vulnerabilities
CVE-2018-8098
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-14 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer overflow in the index.c:read_entry() function while decompressing a compressed prefix length in libgit2 before v0.26.2 allows an attacker to cause a denial of service (out-of-bounds read) via a crafted repository index file.
Affected products
- Debian Linux: 9.0
- libgit2: before 0.26.2 — fixed in 0.26.2
How to fix
Upgrade to a fixed version: libgit2 0.26.2. Check the vendor advisory for mitigations.
References
- https://github.com/libgit2/libgit2/commit/3207ddb0103543da8ad2139ec6539f590f9900c1
- https://github.com/libgit2/libgit2/commit/3db1af1f370295ad5355b8f64b865a2a357bcac0
- https://libgit2.github.com/security/
- https://lists.debian.org/debian-lts-announce/2022/03/msg00031.html
- https://github.com/libgit2/libgit2/commit/3207ddb0103543da8ad2139ec6539f590f9900c1
- https://github.com/libgit2/libgit2/commit/3db1af1f370295ad5355b8f64b865a2a357bcac0
- https://libgit2.github.com/security/
- https://lists.debian.org/debian-lts-announce/2022/03/msg00031.html
Get alerted when CVE-2018-8098 or the next vulnerability affects your stack