What’s Vulnerable › Vulnerabilities
CVE-2018-8099
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-14 · updated 2026-06-17
- Weakness: CWE-415
Description
Incorrect returning of an error code in the index.c:read_entry() function leads to a double free in libgit2 before v0.26.2, which allows an attacker to cause a denial of service via a crafted repository index file.
Affected products
- Debian Linux: 9.0
- libgit2: before 0.26.2 — fixed in 0.26.2
How to fix
Upgrade to a fixed version: libgit2 0.26.2. Check the vendor advisory for mitigations.
References
- https://github.com/libgit2/libgit2/commit/58a6fe94cb851f71214dbefac3f9bffee437d6fe
- https://libgit2.github.com/security/
- https://lists.debian.org/debian-lts-announce/2022/03/msg00031.html
- https://github.com/libgit2/libgit2/commit/58a6fe94cb851f71214dbefac3f9bffee437d6fe
- https://libgit2.github.com/security/
- https://lists.debian.org/debian-lts-announce/2022/03/msg00031.html
Get alerted when CVE-2018-8099 or the next vulnerability affects your stack