What’s Vulnerable › Vulnerabilities
CVE-2018-8291
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 69.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-11 · updated 2026-06-17
- Weakness: CWE-843
Description
A remote code execution vulnerability exists in the way the scripting engine handles objects in memory in Microsoft browsers, aka "Scripting Engine Memory Corruption Vulnerability." This affects ChakraCore, Internet Explorer 11, Microsoft Edge. This CVE ID is unique from CVE-2018-8242, CVE-2018-8283, CVE-2018-8287, CVE-2018-8288, CVE-2018-8296, CVE-2018-8298.
Affected products
- Microsoft ChakraCore: before 1.10.1 — fixed in 1.10.1
- Microsoft Edge: all versions
- Microsoft Internet Explorer 11: 11
- Microsoft ChakraCore: ChakraCore
- Microsoft Edge: Windows 10 for 32-bit Systems, Windows 10 for x64-based Systems, Windows 10 Version 1607 for 32-bit Systems, Windows 10 Version 1607 for x64-based Systems, Windows 10 Version 1703 for 32-bit Systems, Windows 10 Version 1703 for x64-based Systems (+5)
- Microsoft Internet Explorer 11: Windows 10 for 32-bit Systems, Windows 10 for x64-based Systems, Windows 10 Version 1607 for 32-bit Systems, Windows 10 Version 1607 for x64-based Systems, Windows 10 Version 1703 for 32-bit Systems, Windows 10 Version 1703 for x64-based Systems (+12)
How to fix
Upgrade to a fixed version: Microsoft ChakraCore 1.10.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104637
- http://www.securitytracker.com/id/1041256
- http://www.securitytracker.com/id/1041258
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-8291
- https://www.exploit-db.com/exploits/45215/
- http://www.securityfocus.com/bid/104637
- http://www.securitytracker.com/id/1041256
- http://www.securitytracker.com/id/1041258
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-8291
- https://www.exploit-db.com/exploits/45215/
Get alerted when CVE-2018-8291 or the next vulnerability affects your stack