What’s Vulnerable › Vulnerabilities
CVE-2018-8327
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 23.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-11 · updated 2026-06-17
Description
A remote code execution vulnerability exists in PowerShell Editor Services, aka "PowerShell Editor Services Remote Code Execution Vulnerability." This affects PowerShell Editor, PowerShell Extension.
Affected products
- Microsoft Powershell: before 1.7.0 — fixed in 1.7.0
- Microsoft Powershell Editor Services: before 1.7.0 — fixed in 1.7.0
- Microsoft PowerShell Editor: Services
- Microsoft PowerShell Extension: Visual Studio Code
How to fix
Upgrade to a fixed version: Microsoft Powershell 1.7.0; Microsoft Powershell Editor Services 1.7.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104649
- http://www.securitytracker.com/id/1041251
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-8327
- http://www.securityfocus.com/bid/104649
- http://www.securitytracker.com/id/1041251
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-8327
Get alerted when CVE-2018-8327 or the next vulnerability affects your stack