What’s Vulnerable › Vulnerabilities
CVE-2018-8710
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-14 · updated 2026-06-17
- Weakness: CWE-287
Description
A remote code execution issue was discovered in the WooCommerce Products Filter (aka WOOF) plugin before 2.2.0 for WordPress, as demonstrated by the shortcode parameter in a woof_redraw_woof action. The plugin implemented a page redraw AJAX function accessible to anyone without any authentication. WordPress shortcode markup in the "shortcode" parameters would be evaluated. Normally unauthenticated users can't evaluate shortcodes as they are often sensitive.
Affected products
- Woocommerce-Filter Woocommerce Products Filter: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: Woocommerce-Filter Woocommerce Products Filter 2.2.0. Check the vendor advisory for mitigations.
References
- https://sec-consult.com/en/blog/advisories/arbitrary-shortcode-execution-local-file-inclusion-in-woof-pluginus-net/index.html
- https://wordpress.org/plugins/woocommerce-products-filter/#developers
- https://www.woocommerce-filter.com/update-woocommerce-products-filter-v-2-2-0/
- https://sec-consult.com/en/blog/advisories/arbitrary-shortcode-execution-local-file-inclusion-in-woof-pluginus-net/index.html
- https://wordpress.org/plugins/woocommerce-products-filter/#developers
- https://www.woocommerce-filter.com/update-woocommerce-products-filter-v-2-2-0/
Get alerted when CVE-2018-8710 or the next vulnerability affects your stack