What’s Vulnerable › Vulnerabilities
CVE-2018-8716
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 38.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-04-25 · updated 2026-06-17
- Weakness: CWE-79
Description
WSO2 Identity Server before 5.5.0 has XSS via the dashboard, allowing attacks by low-privileged attackers.
Affected products
- WSO2 Identity Server: before 5.5.0 — fixed in 5.5.0
How to fix
Upgrade to a fixed version: WSO2 Identity Server 5.5.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/147330/WSO2-Identity-Server-5.3.0-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2018/Apr/45
- http://www.securityfocus.com/archive/1/541954/100/0/threaded
- https://www.exploit-db.com/exploits/44531/
- https://www.sec-consult.com/en/blog/advisories/multiple-stored-xss-vulnerabilities-in-wso2-carbon-and-dashboard-server/index.html
- http://packetstormsecurity.com/files/147330/WSO2-Identity-Server-5.3.0-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2018/Apr/45
- http://www.securityfocus.com/archive/1/541954/100/0/threaded
- https://www.exploit-db.com/exploits/44531/
- https://www.sec-consult.com/en/blog/advisories/multiple-stored-xss-vulnerabilities-in-wso2-carbon-and-dashboard-server/index.html
Get alerted when CVE-2018-8716 or the next vulnerability affects your stack