What’s Vulnerable › Vulnerabilities
CVE-2018-8768
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-18 · updated 2026-06-17
Description
In Jupyter Notebook before 5.4.1, a maliciously forged notebook file can bypass sanitization to execute JavaScript in the notebook context. Specifically, invalid HTML is 'fixed' by jQuery after sanitization, making it dangerous.
Affected products
- jupyter notebook: before 5.4.1 — fixed in 5.4.1
How to fix
Upgrade to a fixed version: jupyter notebook 5.4.1. Check the vendor advisory for mitigations.
References
- http://openwall.com/lists/oss-security/2018/03/15/2
- https://lists.debian.org/debian-lts-announce/2020/11/msg00033.html
- http://openwall.com/lists/oss-security/2018/03/15/2
- https://lists.debian.org/debian-lts-announce/2020/11/msg00033.html
Get alerted when CVE-2018-8768 or the next vulnerability affects your stack