What’s Vulnerable › Vulnerabilities

CVE-2018-8777

Description

In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker can pass a large HTTP request with a crafted header to WEBrick server or a crafted body to WEBrick server/handler and cause a denial of service (memory consumption).

Affected products

How to fix

Upgrade to a fixed version: Ruby 2.2.10, 2.3.7, 2.4.4, 2.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-8777 or the next vulnerability affects your stack