What’s Vulnerable › Vulnerabilities
CVE-2018-8781
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-23 · updated 2026-06-17
- Weakness: CWE-190
Description
The udl_fb_mmap function in drivers/gpu/drm/udl/udl_fb.c at the Linux kernel version 3.4 and up to and including 4.15 has an integer-overflow vulnerability allowing local users with access to the udldrmfb driver to obtain full read and write permissions on kernel physical pages, resulting in a code execution in kernel space.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- Linux kernel: from 3.4 before 3.16.57; from 3.17 before 3.18.103; from 3.19 before 4.1.52; from 4.2 before 4.4.125; from 4.5 before 4.9.91; from 4.10 before 4.14.31 — fixed in 3.16.57, 3.18.103, 4.1.52, 4.14.31, 4.15.14, 4.4.125
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Linux kernel 3.16.57, 3.18.103, 4.1.52, 4.14.31. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:2948
- https://access.redhat.com/errata/RHSA-2018:3083
- https://access.redhat.com/errata/RHSA-2018:3096
- https://lists.debian.org/debian-lts-announce/2018/05/msg00000.html
- https://patchwork.freedesktop.org/patch/211845/
- https://research.checkpoint.com/mmap-vulnerabilities-linux-kernel/
- https://usn.ubuntu.com/3654-1/
- https://usn.ubuntu.com/3654-2/
- https://usn.ubuntu.com/3656-1/
- https://usn.ubuntu.com/3674-1/
- https://usn.ubuntu.com/3674-2/
- https://usn.ubuntu.com/3677-1/
Get alerted when CVE-2018-8781 or the next vulnerability affects your stack