What’s Vulnerable › Vulnerabilities
CVE-2018-8871
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-25 · updated 2026-06-17
- Weakness: CWE-122
Description
In Delta Electronics Automation TPEditor version 1.89 or prior, parsing a malformed program file may cause heap-based buffer overflow vulnerability, which may allow remote code execution.
Affected products
- Delta Electronics TPEditor: before 1.89 — fixed in 1.89
How to fix
Upgrade to a fixed version: Delta Electronics TPEditor 1.89. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104216
- https://ics-cert.us-cert.gov/advisories/ICSA-18-137-04
- http://www.securityfocus.com/bid/104216
- https://ics-cert.us-cert.gov/advisories/ICSA-18-137-04
Get alerted when CVE-2018-8871 or the next vulnerability affects your stack