What’s Vulnerable › Vulnerabilities
CVE-2018-8910
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in Attachment Preview in Synology Drive before 1.0.1-10253 allows remote authenticated users to inject arbitrary web script or HTML via malicious attachments.
Affected products
- Synology Drive: before 1.0.1-10253 — fixed in 1.0.1-10253
How to fix
Upgrade to a fixed version: Synology Drive 1.0.1-10253. Check the vendor advisory for mitigations.
References
- https://www.synology.com/en-global/support/security/Synology_SA_18_05
- https://www.synology.com/en-global/support/security/Synology_SA_18_05
Get alerted when CVE-2018-8910 or the next vulnerability affects your stack