What’s Vulnerable › Vulnerabilities
CVE-2018-9039
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-27 · updated 2026-06-17
- Weakness: CWE-862
Description
In Octopus Deploy 2.0 and later before 2018.3.7, an authenticated user, with variable edit permissions, can scope some variables to targets greater than their permissions should allow. In other words, they can see machines beyond their team's scoped environments.
Affected products
- Octopus Deploy: from 2.0 before 2018.3.7 — fixed in 2018.3.7
How to fix
Upgrade to a fixed version: Octopus Deploy 2018.3.7. Check the vendor advisory for mitigations.
References
- https://github.com/OctopusDeploy/Issues/issues/4407
- https://octopus.com/downloads/compare?from=2018.3.6&to=2018.3.7
- https://github.com/OctopusDeploy/Issues/issues/4407
- https://octopus.com/downloads/compare?from=2018.3.6&to=2018.3.7
Get alerted when CVE-2018-9039 or the next vulnerability affects your stack