What’s Vulnerable › Vulnerabilities
CVE-2018-9144
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-30 · updated 2026-06-17
- Weakness: CWE-125
Description
In Exiv2 0.26, there is an out-of-bounds read in Exiv2::Internal::binaryToString in image.cpp. It could result in denial of service or information disclosure.
Affected products
- exiv2: before 0.26 — fixed in 0.26
How to fix
Upgrade to a fixed version: exiv2 0.26. Check the vendor advisory for mitigations.
References
- https://github.com/Exiv2/exiv2/issues/254
- https://github.com/xiaoqx/pocs/tree/master/exiv2
- https://security.gentoo.org/glsa/201811-14
- https://github.com/Exiv2/exiv2/issues/254
- https://github.com/xiaoqx/pocs/tree/master/exiv2
- https://security.gentoo.org/glsa/201811-14
Get alerted when CVE-2018-9144 or the next vulnerability affects your stack