What’s Vulnerable › Vulnerabilities

CVE-2018-9243

Description

GitLab Community and Enterprise Editions version 8.4 up to 10.4 are vulnerable to XSS because a lack of input validation in the merge request component leads to cross site scripting (specifically, filenames in changes tabs of merge requests). This is fixed in 10.6.3, 10.5.7, and 10.4.7.

Affected products

How to fix

Upgrade to a fixed version: GitLab 10.4.7, 10.5.7, 10.6.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-9243 or the next vulnerability affects your stack