What’s Vulnerable › Vulnerabilities
CVE-2018-9246
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-08 · updated 2026-06-17
- Weakness: CWE-116
Description
The PGObject::Util::DBAdmin module before 0.120.0 for Perl, as used in LedgerSMB through 1.5.x, insufficiently sanitizes or escapes variable values used as part of shell command execution, resulting in shell code injection via the create(), run_file(), backup(), or restore() function. The vulnerability allows unauthorized users to execute code with the same privileges as the running application.
Affected products
- ledgersmb/ledgersmb: from 1.5.0 through 1.5.21
- Pgobject-Util-Dbadmin Project Pgobject-Util-Dbadmin: before 0.120.0 — fixed in 0.120.0
How to fix
Upgrade to a fixed version: Pgobject-Util-Dbadmin Project Pgobject-Util-Dbadmin 0.120.0. Check the vendor advisory for mitigations.
References
- https://archive.ledgersmb.org/ledger-smb-announce/msg00280.html
- https://archive.ledgersmb.org/ledger-smb-announce/msg00280.html
Get alerted when CVE-2018-9246 or the next vulnerability affects your stack