What’s Vulnerable › Vulnerabilities
CVE-2018-9305
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-04-04 · updated 2026-06-17
- Weakness: CWE-125
Description
In Exiv2 0.26, an out-of-bounds read in IptcData::printStructure in iptc.c could result in a crash or information leak, related to the "== 0x1c" case.
Affected products
- exiv2: before 0.26 — fixed in 0.26
How to fix
Upgrade to a fixed version: exiv2 0.26. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00009.html
- https://access.redhat.com/errata/RHSA-2019:2101
- https://github.com/Exiv2/exiv2/issues/263
- https://github.com/xiaoqx/pocs/blob/master/exiv2/readme.md
- https://security.gentoo.org/glsa/201811-14
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00009.html
- https://access.redhat.com/errata/RHSA-2019:2101
- https://github.com/Exiv2/exiv2/issues/263
- https://github.com/xiaoqx/pocs/blob/master/exiv2/readme.md
- https://security.gentoo.org/glsa/201811-14
Get alerted when CVE-2018-9305 or the next vulnerability affects your stack