What’s Vulnerable › Vulnerabilities
CVE-2018-9336
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-01 · updated 2026-06-17
- Weakness: CWE-415
Description
openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local attacker to cause a double-free of memory by sending a malformed request to the interactive service. This could cause a denial-of-service through memory corruption or possibly have unspecified other impact including privilege escalation.
Affected products
- OpenVPN: from 2.4.0 before 2.4.6 — fixed in 2.4.6
- Slackware Linux: 13.0, 13.1, 13.37, 14.0, 14.1
How to fix
Upgrade to a fixed version: OpenVPN 2.4.6. Check the vendor advisory for mitigations.
References
- http://www.slackware.com/security/viewer.php?l=slackware-security&y=2018&m=slackware-security.568761
- https://community.openvpn.net/openvpn/wiki/ChangesInOpenvpn24
- https://github.com/OpenVPN/openvpn/commit/1394192b210cb3c6624a7419bcf3ff966742e79b
- https://github.com/OpenVPN/openvpn/releases/tag/v2.4.6
- https://www.tenable.com/security/research/tra-2018-09
- http://www.slackware.com/security/viewer.php?l=slackware-security&y=2018&m=slackware-security.568761
- https://community.openvpn.net/openvpn/wiki/ChangesInOpenvpn24
- https://github.com/OpenVPN/openvpn/commit/1394192b210cb3c6624a7419bcf3ff966742e79b
- https://github.com/OpenVPN/openvpn/releases/tag/v2.4.6
- https://www.tenable.com/security/research/tra-2018-09
Get alerted when CVE-2018-9336 or the next vulnerability affects your stack