What’s Vulnerable › Vulnerabilities
CVE-2018-9861
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for CKEditor (in versions 4.5.10 through 4.9.1; fixed in 4.9.2), as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, allows remote attackers to inject arbitrary web script through a crafted IMG element.
Affected products
- ckeditor Enhanced Image: from 4.5.10 before 4.9.2 — fixed in 4.9.2
- Drupal: from 8.0.0 before 8.4.7; from 8.5.0 before 8.5.2 — fixed in 8.4.7, 8.5.2
How to fix
Upgrade to a fixed version: ckeditor Enhanced Image 4.9.2; Drupal 8.4.7, 8.5.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103924
- https://github.com/ckeditor/ckeditor-dev/blob/master/CHANGES.md
- https://www.drupal.org/sa-core-2018-003
- https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
- http://www.securityfocus.com/bid/103924
- https://github.com/ckeditor/ckeditor-dev/blob/master/CHANGES.md
- https://www.drupal.org/sa-core-2018-003
- https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
Get alerted when CVE-2018-9861 or the next vulnerability affects your stack