What’s Vulnerable › Vulnerabilities
CVE-2018-9989
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-10 · updated 2026-06-17
- Weakness: CWE-125
Description
ARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_psk_hint() that could cause a crash on invalid input.
Affected products
- mbedtls: before 2.1.11; from 2.7.0 before 2.7.2 — fixed in 2.1.11, 2.7.2
- Debian Linux: 8.0, 9.0
- TrustedFirmware Mbed TLS: 2.8.0-rc1
How to fix
Upgrade to a fixed version: mbedtls 2.1.11, 2.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/ARMmbed/mbedtls/commit/5224a7544c95552553e2e6be0b4a789956a6464e
- https://github.com/ARMmbed/mbedtls/commit/740b218386083dc708ce98ccc94a63a95cd5629e
- https://lists.debian.org/debian-lts-announce/2018/09/msg00029.html
- https://lists.debian.org/debian-lts-announce/2021/11/msg00021.html
- https://tls.mbed.org/tech-updates/releases/mbedtls-2.8.0-2.7.2-and-2.1.11-released
- https://github.com/ARMmbed/mbedtls/commit/5224a7544c95552553e2e6be0b4a789956a6464e
- https://github.com/ARMmbed/mbedtls/commit/740b218386083dc708ce98ccc94a63a95cd5629e
- https://lists.debian.org/debian-lts-announce/2018/09/msg00029.html
- https://lists.debian.org/debian-lts-announce/2021/11/msg00021.html
- https://tls.mbed.org/tech-updates/releases/mbedtls-2.8.0-2.7.2-and-2.1.11-released
Get alerted when CVE-2018-9989 or the next vulnerability affects your stack