What’s Vulnerable › Vulnerabilities
CVE-2019-0008: QFX5000 Series, EX4300, EX4600: A stack buffer overflow vulnerability in Packet Forwarding Engine manager (FXPC) process
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-10 · updated 2026-06-17
- Weakness: CWE-121
Description
A certain sequence of valid BGP or IPv6 BFD packets may trigger a stack based buffer overflow in the Junos OS Packet Forwarding Engine manager (FXPC) process on QFX5000 series, EX4300, EX4600 devices. This issue can result in a crash of the fxpc daemon or may potentially lead to remote code execution. Affected releases are Juniper Networks Junos OS on QFX 5000 series, EX4300, EX4600 are: 14.1X53; 15.1X53 versions prior to 15.1X53-D235; 17.1 versions prior to 17.1R3; 17.2 versions prior to 17.2R3; 17.3 versions prior to 17.3R3-S2, 17.3R4; 17.4 versions prior to 17.4R2-S1, 17.4R3; 18.1 versions prior to 18.1R3-S1, 18.1R4; 18.2 versions prior to 18.2R2; 18.2X75 versions prior to 18.2X75-D30; 18.3 versions prior to 18.3R2.
Affected products
- Juniper Junos OS: from 15.1x53 before 15.1x53-d235; from 17.1 before 17.1r3; from 17.2 before 17.2r3; from 17.3 before 17.3r3-s2; from 17.4 before 17.4r2-s1; from 18.1 before 18.1r3-s1 — fixed in 15.1x53-d235, 17.1r3, 17.2r3, 17.3r3-s2, 17.4r2-s1, 18.1r3-s1
How to fix
Upgrade to a fixed version: Juniper Junos OS 15.1x53-d235, 17.1r3, 17.2r3, 17.3r3-s2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107897
- https://kb.juniper.net/JSA10930
- http://www.securityfocus.com/bid/107897
- https://kb.juniper.net/JSA10930
Get alerted when CVE-2019-0008 or the next vulnerability affects your stack