What’s Vulnerable › Vulnerabilities
CVE-2019-0039: Junos OS: Login credentials are vulnerable to brute force attacks through the REST API
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-10 · updated 2026-06-17
- Weakness: CWE-307
Description
If REST API is enabled, the Junos OS login credentials are vulnerable to brute force attacks. The high default connection limit of the REST API may allow an attacker to brute-force passwords using advanced scripting techniques. Additionally, administrators who do not enforce a strong password policy can increase the likelihood of success from brute force attacks. Affected releases are Juniper Networks Junos OS: 14.1X53 versions prior to 14.1X53-D49; 15.1 versions prior to 15.1F6-S12, 15.1R7-S3; 15.1X49 versions prior to 15.1X49-D160; 15.1X53 versions prior to 15.1X53-D236, 15.1X53-D495, 15.1X53-D591, 15.1X53-D69; 16.1 versions prior to 16.1R3-S10, 16.1R4-S12, 16.1R6-S6, 16.1R7-S3; 16.1X65 versions prior to 16.1X65-D49; 16.2 versions prior to 16.2R2-S7; 17.1 versions prior to 17.1R2-S10, 17.1R3; 17.2 versions prior to 17.2R1-S8, 17.2R3-S1; 17.3 versions prior to 17.3R3-S2; 17.4 versions prior to 17.4R1-S6, 17.4R2-S2; 18.1 versions prior to 18.1R2-S4, 18.1R3-S1; 18.2 versions prior to 18.2R1-S5; 18.2X75 versions prior to 18.2X75-D30; 18.3 versions prior to 18.3R1-S1.
Affected products
- Juniper Junos OS: from 14.1x53 before 14.1x53-d49; from 15.1 before 15.1f6-s12; from 15.1x49 before 15.1x49-d160; from 15.1x53 before 15.1x53-d236; from 16.1 before 16.1r3-s10; from 16.1x65 before 16.1x65-d49 — fixed in 14.1x53-d49, 15.1f6-s12, 15.1x49-d160, 15.1x53-d236, 16.1r3-s10, 16.1x65-d49
How to fix
Upgrade to a fixed version: Juniper Junos OS 14.1x53-d49, 15.1f6-s12, 15.1x49-d160, 15.1x53-d236. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107899
- https://kb.juniper.net/JSA10928
- http://www.securityfocus.com/bid/107899
- https://kb.juniper.net/JSA10928
Get alerted when CVE-2019-0039 or the next vulnerability affects your stack