What’s Vulnerable › Vulnerabilities
CVE-2019-0204
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-25 · updated 2026-06-17
Description
A specifically crafted Docker image running under the root user can overwrite the init helper binary of the container runtime and/or the command executor in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.2, 1.6.0 to 1.6.1, and 1.7.0 to 1.7.1. A malicious actor can therefore gain root-level code execution on the host.
Affected products
- Apache Software Foundation Apache Mesos: from 1.4.0 before 1.4.3; from 1.5.0 before 1.5.3; from 1.6.0 before 1.6.2; from 1.7.0 before 1.7.2; 1.8.0-dev — fixed in 1.4.3, 1.5.3, 1.6.2, 1.7.2
- Red Hat Fuse: 7.5.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Mesos 1.4.3, 1.5.3, 1.6.2, 1.7.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107605
- https://access.redhat.com/errata/RHSA-2019:3892
- https://lists.apache.org/thread.html/b162dd624dc088cd634292f0402282a1d1d0ce853baeae8205bc033c%40%3Cdev.mesos.apache.org%3E
- http://www.securityfocus.com/bid/107605
- https://access.redhat.com/errata/RHSA-2019:3892
- https://lists.apache.org/thread.html/b162dd624dc088cd634292f0402282a1d1d0ce853baeae8205bc033c%40%3Cdev.mesos.apache.org%3E
Get alerted when CVE-2019-0204 or the next vulnerability affects your stack