What’s Vulnerable › Vulnerabilities
CVE-2019-1000006
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-04 · updated 2026-06-17
- Weakness: CWE-787
Description
RIOT RIOT-OS version after commit 7af03ab624db0412c727eed9ab7630a5282e2fd3 contains a Buffer Overflow vulnerability in sock_dns, an implementation of the DNS protocol utilizing the RIOT sock API that can result in Remote code executing. This attack appears to be exploitable via network connectivity.
Affected products
- RIOT-OS RIOT: from 2017.04 before 2018.10.1 — fixed in 2018.10.1
How to fix
Upgrade to a fixed version: RIOT-OS RIOT 2018.10.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-1000006 or the next vulnerability affects your stack