What’s Vulnerable › Vulnerabilities
CVE-2019-1000008
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-04 · updated 2026-06-17
- Weakness: CWE-22
Description
All versions of Helm between Helm >=2.0.0 and < 2.12.2 contains a CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in The commands `helm fetch --untar` and `helm lint some.tgz` that can result when chart archive files are unpacked a file may be unpacked outside of the target directory. This attack appears to be exploitable via a victim must run a helm command on a specially crafted chart archive. This vulnerability appears to have been fixed in 2.12.2.
Affected products
- helm: from 2.0.0 before 2.12.2 — fixed in 2.12.2
How to fix
Upgrade to a fixed version: helm 2.12.2. Check the vendor advisory for mitigations.
References
- https://helm.sh/blog/helm-security-notice-2019/index.html
- https://helm.sh/blog/helm-security-notice-2019/index.html
Get alerted when CVE-2019-1000008 or the next vulnerability affects your stack