What’s Vulnerable › Vulnerabilities
CVE-2019-1000022
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-04 · updated 2026-06-17
- Weakness: CWE-352
Description
Taoensso Sente version Prior to version 1.14.0 contains a Cross Site Request Forgery (CSRF) vulnerability in WebSocket handshake endpoint that can result in CSRF attack, possible leak of anti-CSRF token. This attack appears to be exploitable via malicious request against WebSocket handshake endpoint. This vulnerability appears to have been fixed in 1.14.0 and later.
Affected products
- Taoensso Sente: before 1.14.0 — fixed in 1.14.0
How to fix
Upgrade to a fixed version: Taoensso Sente 1.14.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-1000022 or the next vulnerability affects your stack