What’s Vulnerable › Vulnerabilities
CVE-2019-10010
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library before 0.18.3 allows remote attackers to insert unsafe links into HTML by using double-encoded HTML entities that are not properly escaped during rendering, a different vulnerability than CVE-2018-20583.
Affected products
- thephpleague commonmark: before 0.18.3 — fixed in 0.18.3
How to fix
Upgrade to a fixed version: thephpleague commonmark 0.18.3. Check the vendor advisory for mitigations.
References
- https://github.com/thephpleague/commonmark/issues/353
- https://github.com/thephpleague/commonmark/releases/tag/0.18.3
- https://github.com/thephpleague/commonmark/issues/353
- https://github.com/thephpleague/commonmark/releases/tag/0.18.3
Get alerted when CVE-2019-10010 or the next vulnerability affects your stack